I can't compile anything in GPL.BP!

From ScarletDME
Revision as of 21:14, 20 March 2009 by Geneb (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Programs that live in GPL.BP are for the most part "internal" programs. As such, they need to be compiled in a special way.

You may have seen errors similar to those below:

******
69: Unrecognised compiler directive
*
73: Misformed $CATALOGUE

This means that you didn't start OpenQM with the "internal" directive.

Quit out of OpenQM and restart it using the "-internal" option.

/usr/qmsys/bin/qm -internal

You should then be able to compile programs that use the $internal compiler directive as well as the extended version of the $catalogue directive.